TRUNK实验


Trunk的简单介绍:

Trunk,也叫Trunk接口,中文名称:中继接口,是交换机连接交换机的接口(级联接口),中继接口不需要关联任何一个VLAN,默认允许所有VLAN流量通过,中继接口可以实现一个交换区块内所有交换机共享相同的VLAN信息。

在交换机之间如果需要承载多个VLAN流量通过时,就需要多个VLAN数目相同的链路,但为了节约链路和接口,就需要Trunk接口,Trunk接口允许多个VLAN流量在同一个链路进行转发,通过Ethernet2帧中的Tag(标签)字段指定VLAN流量的归属,再基于帧把相应的VLAN信息进行转发。

Ethernet 2携带802.1Q帧格式:

frame

携带Tag帧的解释:

TPID:这是一个固定值,0x8100 ,目的是表明这是一个携带802.1Q标签的帧,如果不支持802.1Q的设备接收到此数据帧,就会丢弃。

PRI:表示帧的优先级(Priority),取值范围为:0 - 7,当值的优先级越大,交换机在阻塞时,会优先发送优先级最大的数据帧。

CFI:表示mac地址是否为标准格式,CFI为0,则表示这是一个标准的mac地址格式,如果为1,则表示这是一个非标准的mac地址格式,一般用于区分以太网帧、FDDI帧和令牌环网帧。

VLAN ID:表示该帧所属的VLAN,可配置的VLAN ID为1-4094,0和4095规定为保留的VLAN ID。

本征VLAN:

本征VLAN(Native VLAN),由于802.1Q只支持Ethernet 2 的帧格式,不支持802.3的数据封装,所以在交换机中设置一个本征vlan,并且只有一个本征vlan,默认为 1(可修改), 作用为数据帧在转发时可以不打标签(tag)。交换机的中继链路收到一个没有打标签的数据帧,会认为这是本征vlan的数据帧,然后进行数据转发。 使用时,两端中继链路的本征VLAN必须保持一致。

Trunk的实验:

拓扑图

实验目的:

划分各交换机的VLAN为:10和20,并且在交换机之间的互联接口设置为中继接口,只允许放行VLAN10和20,使VPC和VPC3,VPC2和VPC4各在所属的VLAN域内,并能够通信。

修改交换机的主机名:

Switch(config)#hostname SW1(修改交换机的主机名)
Switch(config)#hostname SW2

配置VPC的IP地址:

SW1:
VPCS>ip 192.168.10.1 255.255.255.0 
VPCS>ip 192.168.10.2 255.255.255.0
SW2:
VPC:ip 192.168.10.3 255.255.255.0 
VPCS:ip 192.168.10.4 255.255.255.0

配置交换机SW1的VLAN划分和中继链路:

SW1(config)#vlan 10 (创建vlan10)
SW1(config)#vlan 20
SW1(config)#interface ethernet 0/0 (进入VPC所连接的交换机接口) 
SW1(config-if)#switchport mode access (配置接口为Access接口) 
SW1(config-if)#switchport access vlan 10 (划分VLAN10到此接口)
SW1(config)#interface ethernet 0/1 
SW1(config-if)#switchport mode access 
SW1(config-if)#switchport access vlan 20
SW1(config)#interface ethernet 0/3 (进入和SW2互联的接口) 
SW1(config-if)#switchport trunk encapsulation dot1q (因为思科交换机中继接口有思科的私有协议ISL,所以需要设置封装为802.1Q) 
SW1(config-if)#switchport mode trunk (配置为中继链路)
SW1(config-if)#switchport trunk allowed vlan 10,20 (配置中继链路只允许VLAN10和VLAN20通过)
SW1(config-if)#switchport trunk native vlan xx(配置本征vlan,如果不理解本征vlan请不要修改,默认就行)

同理在交换机SW2配置VLAN划分和中继链路:

SW2(config)#vlan 10 
SW2(config)#vlan 20
SW2(config)#interface ethernet 0/0 
SW2(config-if)#switchport mode access 
SW2(config-if)#switchport access vlan 10
SW2(config)#interface ethernet 0/1 
SW2(config-if)#switchport mode access 
SW2(config-if)#switchport access vlan 20
SW2(config)#interface ethernet 0/3 
SW2(config-if)#switchport trunk encapsulation dot1q 
SW2(config-if)#switchport mode trunk 
SW2(config-if)#switchport trunk allowed vlan 10,20 

查看VLAN表和接口中继信息:

vlan table

VLAN表内的相应接口已经划分到vlan内,并且状态为active。

trunk接口信息

接口的中继信息模式(mode)为开启,并且使用的协议为802.1q,状态为trunking,放行的vlan为10,20。

配置完成后,进行ping测试:

VPC测试:

ping测试

ping测试

VPC2测试:

ping测试

ping测试

经过ping测试后,所属的vlan域内可以跨交换机进行通信,不是所属的vlan域内不能进行通信。


文章作者: Naraku
版权声明: 本博客所有文章除特別声明外,均采用 CC BY 4.0 许可协议。转载请注明来源 Naraku !
  目录