单臂路由实验


单臂路由的简单介绍:

单臂路由,是指在一个路由器的接口上创建子接口(也可称为逻辑接口),实现原本相互隔离的不同VLAN(虚拟局域网)之间的相互通信。

优点:仅仅只能更好的理解子接口和VLAN原理以及交换机不同vlan之间的通信,没有现实意义。

缺点:容易造成单点故障,当主接口被关闭或者开启,子接口也会随主接口关闭或者开启。

单臂路由的实验:

拓扑图

实验目的:

在交换机SW1上创建vlan10和vlan20,并设置上联接口为Trunk,只允许放行vlan10和vlan20,然后在路由器R1上创建子接口,并封装子接口流量为802.1q,相应的vlan打上相应的vlan标记。

IP地址表:

R1 二层或三层配置 SW1 二层或三层配置
ethernet0/0 no shutdown ethernet0/0 Trunk
ethernet0/0.10 192.168.10.254/24 ethernet0/1 vlan 10
ethernet0/0.20 192.168.20.254/24 ethernet0/2 vlan 20

修改路由器和交换机的主机名:

Router(config)#hostname R1 
Switch(config)#hostname SW1

配置VPC的IP地址和网关:

VPCS>ip 192.168.10.1 255.255.255.0 192.168.10.254 
VPCS>ip 192.168.20.1 255.255.255.0 192.168.20.254

配置交换机SW1的VLAN划分和中继链路:

SW1(config)#vlan 10 (创建vlan10) 
SW1(config)#vlan 20
SW1(config)#interface ethernet 0/1 (进入VPC所连接的交换机接口)
SW1(config-if)#switchport mode access (配置接口为Access接口)
SW1(config-if)#switchport access vlan 10 (划分VLAN10到此接口)
SW1(config)#interface ethernet 0/2 
SW1(config-if)#switchport mode access 
SW1(config-if)#switchport access vlan 20
SW1(config)#interface ethernet 0/0 (进入和R1互联的接口)
SW1(config-if)#switchport trunk encapsulation dot1q (因为思科交换机中继接口有思科的私有协议ISL,所以需要设置封装为802.1Q)
SW1(config-if)#switchport mode trunk (配置为中继链路)
SW1(config-if)#switchport trunk allowed vlan 10,20 (配置中继链路只允许VLAN10和VLAN20通过)

配置路由器R1的主接口启用和子接口:

R1(config)#interface ethernet 0/0(进入和SW1互联的接口)
R1(config-if)#no shutdown(接口开启)
R1(config)#interface ethernet 0/0.10(创建子接口0/0.10)
R1(config-subif)#encapsulation dot1Q 10(设置接口的封装类型为802.1Q, 并把该接口划分到vlan10)
R1(config-subif)#ip address 192.168.10.254 255.255.255.0(设置VPC的网关IP地址)
R1(config)#interface ethernet 0/0.20
R1(config-subif)#encapsulation dot1Q 20
R1(config-subif)#ip address 192.168.20.254 255.255.255.0

查看R1的路由表和IP地址表:

路由表

查看R1所显示的路由表信息,已经有两条路由,并显示的对应的子接口。

ip地址表

已经显示创建好的子接口,和IP地址,链路状态和链路协议都为UP。

配置完成后,进行ping测试:

VPC3测试:

ping测试

VPC4测试:

ping测试

经过ping测试后,所有的VPC可以跨VALN域进行通信。


文章作者: Naraku
版权声明: 本博客所有文章除特別声明外,均采用 CC BY 4.0 许可协议。转载请注明来源 Naraku !
  目录