华为1+x(中级)实验1


华为1+X《网络系统建设与运维(中级)》认证实验(1)

拓扑图

VLAN信息表:

LSW1 链路类型 VLAN参数 LSW2 链路类型 VLAN参数
GE0/0/1 Trunk Allow pass:1,10,20 Eth-Trunk1 Trunk Allow pass:1,10,20
GE0/0/2 Trunk Allow pass:1,10,20 N/A N/A N/A
GE0/0/5 Trunk Allow pass:1,10,20 N/A N/A N/A
Eth-Trunk1 Trunk Allow pass:1,10,20 N/A N/A N/A
LSW3 链路类型 VLAN参数 LSW4 链路类型 VLAN参数
GE0/0/1 Trunk Allow pass:1,10,20 GE0/0/1 Trunk Allow pass:1,10,20
GE0/0/2 Trunk Allow pass:1,10,20 GE0/0/2 Trunk Allow pass:1,10,20
Eth0/0/1 Access VLAN 10 Eth0/0/1 Access VLAN 20

IP地址表:

R1 IP地址 R2 IP地址 R3 IP地址
GE0/0/0.10 192.168.10.254/24 GE0/0/1 10.2.34.3/24 GE0/0/0 10.2.34.4/24
GE0/0/0.20 192.168.20.254/24 GE0/0/2 3.2.1.2/30 GE0/0/1 10.2.45.4/24
GE0/0/1 1.2.3.1/30 Loopback0 3.3.3.3/32 Loopback0 4.4.4.4/32
GE0/0/2 3.2.1.1/30 N/A N/A N/A N/A
R4 IP地址 N/A N/A Internet IP地址
GE0/0/0 10.2.45.5/24 N/A N/A GE0/0/1 1.2.3.2/30
Loopback0 5.5.5.5/32 N/A N/A N/A N/A

链路聚合配置:

园区本地服务器区,为校园用户提供内网服务。为了保证链路的稳定性同时在不升级硬件设备的前提下最大限度的提升带宽。在LSW1与LSW2之间配置链路聚合。请通过Lacp模式实现二层链路聚合,成员接口为GE0/0/3、GE0/0/4,链路聚合接口ID为1。

LSW1:
[LSW1]interface Eth-Trunk 1
[LSW1-Eth-Trunk1]mode lacp-static
[LSW1-Eth-Trunk1]trunkport GigabitEthernet 0/0/3 0/0/4
LSW2:
[LSW2]interface Eth-Trunk 1
[LSW1-Eth-Trunk1]mode lacp-static
[LSW2-Eth-Trunk1]trunkport GigabitEthernet 0/0/3 0/0/4

VLAN&Trunk配置:

全网设备按照要求配置所需的VLAN 。请根据VLAN信息表,在对应交换机上配置所需的VLAN 。注意:为了保证网络的连通性,交换机只允许题目中规定的VLAN通过。

LSW1:
[LSW1]vlan batch 10 20
[LSW1]interface GigabitEthernet 0/0/1
[LSW1-GigabitEthernet0/0/1]port link-type trunk 
[LSW1-GigabitEthernet0/0/1]port trunk allow-pass vlan 1,10,20

[LSW1]interface GigabitEthernet 0/0/2
[LSW1-GigabitEthernet0/0/2]port link-type trunk 
[LSW1-GigabitEthernet0/0/2]port trunk allow-pass vlan 1,10,20

[LSW1]interface GigabitEthernet 0/0/5
[LSW1-GigabitEthernet0/0/5]port link-type trunk 
[LSW1-GigabitEthernet0/0/5]port trunk allow-pass vlan 1,10,20
[LSW1]interface Eth-Trunk 1
[LSW1-Eth-Trunk1]port link-type trunk 
[LSW1-Eth-Trunk1]port trunk allow-pass vlan 1,10,20
LSW2:
[LSW2]vlan batch 10 20
[LSW1]interface Eth-Trunk 1
[LSW1-Eth-Trunk1]port link-type trunk 
[LSW1-Eth-Trunk1]port trunk allow-pass vlan 1,10,20
LSW3:
[LSW3]vlan batch 10 20
[LSW3]interface Ethernet0/0/1
[LSW3-Ethernet0/0/1]port link-type access
[LSW3-Ethernet0/0/1]port default vlan 10
[LSW3]interface GigabitEthernet 0/0/1
[LSW3-GigabitEthernet0/0/1]port link-type trunk 
[LSW3-GigabitEthernet0/0/1]port trunk allow-pass vlan 1 10 20

[LSW3]interface GigabitEthernet 0/0/2
[LSW3-GigabitEthernet0/0/2]port link-type trunk 
[LSW3-GigabitEthernet0/0/2]port trunk allow-pass vlan 1 10 20
LSW4:
[LSW4]vlan batch 10 20
[LSW4]interface Ethernet0/0/1
[LSW4-Ethernet0/0/1]port link-type access
[LSW4-Ethernet0/0/1]port default vlan 20
[LSW4]interface GigabitEthernet 0/0/1
[LSW4-GigabitEthernet0/0/1]port link-type trunk 
[LSW4-GigabitEthernet0/0/1]port trunk allow-pass vlan 1 10 20

[LSW4]interface GigabitEthernet 0/0/2
[LSW4-GigabitEthernet0/0/2]port link-type trunk 
[LSW4-GigabitEthernet0/0/2]port trunk allow-pass vlan 1 10 20

IP地址配置:

请根据实验拓扑和IP地址表给出的信息,配置对应网络设备接口的IP地址。

R1:
[R1]interface GigabitEthernet0/0/0.10
[R1-GigabitEthernet0/0/0.10]dot1q termination vid 20
[R1-GigabitEthernet0/0/0.10]ip address 192.168.10.254 24
[R1-GigabitEthernet0/0/0.10]arp broadcast enable

[R1]interface GigabitEthernet0/0/0.20
[R1-GigabitEthernet0/0/0.20]dot1q termination vid 20
[R1-GigabitEthernet0/0/0.10]ip address 192.168.20.254 24
[R1-GigabitEthernet0/0/0.20]arp broadcast enable
[R1]interface GigabitEthernet0/0/1
[R1-GigabitEthernet0/0/1]ip address 1.2.3.1 30

[R1]interface GigabitEthernet0/0/2
[R1-GigabitEthernet0/0/2]ip address 3.2.1.1 30
R2:
[R2]interface GigabitEthernet0/0/1
[R2-GigabitEthernet0/0/1]ip address 10.2.34.3 24

[R2]interface GigabitEthernet 0/0/2
[R2-GigabitEthernet0/0/2]ip address 3.2.1.2 30
[R2]interface LoopBack 0
[R2-LoopBack0]ip address 3.3.3.3 32
R3:
[R3]interface GigabitEthernet0/0/0
[R3-GigabitEthernet0/0/0]ip address 10.2.34.4 24

[R3]interface GigabitEthernet0/0/1
[R3-GigabitEthernet0/0/1]ip address 10.2.45.4 24
[R3]interface LoopBack 0
[R3-LoopBack0]ip address 4.4.4.4 32
R4:
[R4]interface GigabitEthernet0/0/0
[R4-GigabitEthernet0/0/0]ip address 10.2.45.5 24
[R4]interface LoopBack 0
[R4-LoopBack0]ip address 5.5.5.5 32
Internet:
[Internet]interface GigabitEthernet0/0/1
[Internet-GigabitEthernet0/0/1]ip address 1.2.3.2 30
PC1:

IP地址

PC2:

IP地址

RSTP协议配置:

为了防止二层网络中出现环路和提高网络可靠性,在LSW1、LSW3和LSW4之间配置STP协议 。

1.STP模式为RSTP。设置LSW1的优先级为4096使其成为根桥 。

2.为了最大限度的保证网络的稳定性避免主机频繁重启导致的网络波动。要求所有与PC相连的交换机端口不参加STP计算直接进入Forwarding状态转发。

LSW1:
[LSW1]stp mode rstp 
[LSW1]stp priority 4096
LSW3-4:
[LSW3]stp mode rstp 
[LSW3]interface Ethernet0/0/1
[LSW3-Ethernet0/0/1]stp edged-port enable 
[LSW4]stp mode rstp 
[LSW4]interface Ethernet0/0/1
[LSW4-Ethernet0/0/1]stp edged-port enable 

出口设计:

为了能够让校园用户访问互联网和通过教育骨干网访问其他学校的资料库。在R1上部署两条缺省的静态路由,下一跳分别指向Internet和R2。
在R2上部署明细静态路由,目的网段是192.168.20.0/24下一跳指向R1。

在Internet上部署明细静态路由目的网段是192.168.10.0/24下一跳指向R1。

为了实现内网192.168.10.0/24网段用户能够访问外网Internet,在R1上配置NAT,结合ACL permit语句使用Easy IP实现。

为了保证教育骨干网的安全只允许内网192.168.20.0/24网段用户能够访问其他学校的资料库。结合ACL permit语句在R1接口的出方向实现 。
以上ACL均使用基本ACL编号2000匹配192.168.10.0/24网段。编号2001匹配192.168.20.0/24网段,rule编号从5开始,采用默认步长。

R2:
[R2]ip route-static 192.168.20.0 24 3.2.1.1
Internet:
[Internet]ip route-static 192.168.10.0 24 1.2.3.1
R1:
[R1]IP route-static 0.0.0.0 0.0.0.0 1.2.3.2
[R1]IP route-static 0.0.0.0 0.0.0.0 3.2.1.2
[R1]acl number 2000
[R1-acl-basic-2000]rule 5 permit source 192.168.10.0 0.0.0.255
[R1]interface GigabitEthernet0/0/1
[R1-GigabitEthernet0/0/1]nat outbound 2000
[R1]ACL number 2001
[R1-acl-basic-2001]rule 5 permit source 192.168.20.0 0.0.0.255
[R1]interface GigabitEthernet 0/0/2
[R1-GigabitEthernet0/0/2]traffic-filter outbound acl 2001 

OSPF配置:

为了保证教育骨干网之间的通信,选用动态路由协议OSPF作为教育骨干网的IGP。

1.R2、R3和R4之间运行OSPF,配置OSP进程号为1都在骨干区域0内。

2.在创建OSPF进程时手动设定进程时手动设定Router ID与环回口地址一致。要求与环回口地址一致。要求互联接口和和Loopback接口所在接口所在网段采用网段采用32位精确宣告。

3.为了保证路由交互的安全性在R2、R3和R4上采用区域认证,选择md5加密算法,认证密钥ID为1密钥类型为 cipher 密码为huawei123。

R2:
[R2]ospf 1 router-id 3.3.3.3
[R2-ospf-1]area 0
[R2-ospf-1-area-0.0.0.0]network 10.2.34.3 0.0.0.0
[R2-ospf-1-area-0.0.0.0]network 3.3.3.3 0.0.0.0 
[R2-ospf-1-area-0.0.0.0]authentication-mode md5 1 cipher huawei123 
R3:
[R3]ospf 1 router-id 4.4.4.4
[R3-ospf-1]area 0
[R3-ospf-1-area-0.0.0.0]network 10.2.34.4 0.0.0.0
[R3-ospf-1-area-0.0.0.0]network 10.2.45.4 0.0.0.0
[R3-ospf-1-area-0.0.0.0]network 4.4.4.4 0.0.0.0
[R3-ospf-1-area-0.0.0.0]authentication-mode md5 1 cipher huawei123
R4:
[R4]ospf 1 router-id 5.5.5.5
[R4-ospf-1]area 0
[R4-ospf-1-area-0.0.0.0]network 10.2.45.5 0.0.0.0	
[R4-ospf-1-area-0.0.0.0]network 5.5.5.5 0.0.0.0
[R4-ospf-1-area-0.0.0.0]authentication-mode md5 1 cipher huawei123

路由引入配置:

为了使内网用户能够通过教育骨干网和其他校区正常通信,在R2上将静态路由引入OSPF。

[R2]ospf 1 router-id 3.3.3.3
[R2-ospf-1]import-route static 

Telnet协议配置:

为了方便后期对R1进行远程管理需在该设备上配置远程登录设置。
用户认证方式为AAA认证,用户名为huawei,密码为Huawei@123,加密形式为cipher,服务类型为telnet,配置服务器的用户权限等级为3级,设置同时在线人数为5人,认证方式为aaa。

[R1]telnet server enable 
[R1]user-interface maximum-vty 5 
[R1]user-interface vty 0 4
[R1-ui-vty0-4]authentication-mode aaa 
[R1-ui-vty0-4]protocol inbound telnet 
[R1]aaa
[R1-aaa]local-user huawei password cipher Huawei@123
[R1-aaa]local-user huawei service-type telnet
[R1-aaa]local-user huawei privilege level 3

文章作者: Naraku
版权声明: 本博客所有文章除特別声明外,均采用 CC BY 4.0 许可协议。转载请注明来源 Naraku !
  目录