链路聚合实验


链路聚合的简单介绍:

链路聚合(Link Aggregation):是指多个物理接口汇聚成一个逻辑接口,实现提升带宽,链路传输弹性,链路冗余技术。

当Trunk链路需要承载几十个或者上百个VLAN的流量时,单个Trunk链路需要承载的流量会成倍的增加,会导致trunk链路拥塞,虽然可以增加上行的Trunk链路,但因不具备冗余和增加链路带宽,这不是一个很好的解决方法,而以太网链路聚合会把多个Trunk链路聚合捆绑成一个逻辑链路,提升带宽和链路冗余,即使某个端口down,也能保证数据传输、可靠性和整体的的传输通道不受影响。

捆绑端口必须属于truck模式;具有相同的 native-vlan ID;每个接口都必须有相同的速度和双工模式;生成树设置必须一致。

以太信道的工作方式:

一共有三种方式,分别是:静态方式、公有标准 LACP(链路汇聚控制协议)、思科私有标准 PAgP(端口汇聚协议)

LACP:

active模式:积极主动协商以太信道,并发送LACPDU(链路汇聚控制协议数据单元)与对端交互信息,通过LACPDU向对端通告自己的系统优先级,系统mac地址,端口优先级,端口号和操作 key,然后根据这些信息选择合适的链路控制聚合的状态。
passive模式:不会主动发送LACPDU,但收到LACPDU后,会被动的进入协商状态。

PAgP:

desirable模式:积极主动协商以太信道,并发送PAgP数据包,与对端交互信息。
auto模式:不会主动发送PAgP数据包,但收到PAgP数据包后,会被动的进入协商状态。

链路聚合的负载均衡方式:

为了避免数据包乱序的情况发生,负载均衡可以把数据包通过某种负载均衡的方式转发到物理链路上,以下是负载均衡的方式:

负载方式 源负载 目的负载 源到目的负载
IP src-ip dst-ip src-dst-ip
MAC src-mac dst-mac src-dst-mac

链路聚合的实验:

拓扑图

实验目的:

在交换机SW1和SW2上创建vlan10和vlan20,并设置上联两个接口为Trunk,只允许放行vlan10和vlan20,再创建链路聚合口,端口号为12,SW1设置为主动协商模式;SW2设置为被动协商模式,负载均衡模式为源ip到目的ip,实现跨交换机的vlan域内pc通信。

IP地址表:

SW1 二层或三层配置 SW2 二层或三层配置
ethernet0/0 Trunk ethernet0/0 Trunk
ethernet0/1 Trunk ethernet0/1 Trunk
ethernet0/2 Access ethernet0/2 Access
ethernet0/3 Access ethernet0/3 Access

VPC3 二层或三层配置 VPC4 二层或三层配置
ethernet0/0 192.168.10.1/24 ethernet0/0 192.168.20.1/24
VPC5 二层或三层配置 VPC6 二层或三层配置
ethernet0/0 192.168.10.2/24 ethernet0/0 192.168.20.2/24

修改路由器和交换机的主机名:

Switch(config)#hostname SW1
Switch(config)#hostname SW2

配置VPC的IP地址:

VPCS> ip 192.168.10.1 255.255.255.0
VPCS> ip 192.168.20.1 255.255.255.0
VPCS> ip 192.168.10.2 255.255.255.0
VPCS> ip 192.168.20.2 255.255.255.0

配置交换机SW1和SW2的VLAN划分和中继链路:

SW1:
SW1(config)#vlan 10
SW1(config)#vlan 20
SW1(config)#interface ethernet 0/2
SW1(config-if)#switchport mode access 
SW1(config-if)#switchport access vlan 10
SW1(config)#interface ethernet 0/3
SW1(config-if)#switchport mode access 
SW1(config-if)#switchport access vlan 20
SW1(config)#interface range ethernet 0/0-1(range是批量进入端口的命令)
SW1(config-if-range)#shutdown(配置链路聚合最好把端口关闭,避免链路状态起不来)
SW1(config-if-range)#switchport trunk encapsulation dot1q 
SW1(config-if-range)#switchport mode trunk 
SW1(config-if-range)#switchport trunk allowed vlan 10,20
SW2:
SW2(config)#vlan 10
SW2(config)#vlan 20
SW2(config)#interface ethernet 0/2
SW2(config-if)#switchport mode access 
SW2(config-if)#switchport access vlan 10
SW2(config)#interface ethernet 0/3
SW2(config-if)#switchport mode access 
SW2(config-if)#switchport access vlan 20
SW2(config)#interface range ethernet 0/0-1
SW2(config-if-range)#shutdown(配置链路聚合最好把端口关闭,避免链路状态起不来)
SW2(config-if-range)#switchport trunk encapsulation dot1q 
SW2(config-if-range)#switchport mode trunk 
SW2(config-if-range)#switchport trunk allowed vlan 10,20

创建链路聚合口12并绑定以太网0/0-1口:

SW1(config)#interface port-channel 12(创建链路聚合口12)
SW1(config-if)#switchport trunk encapsulation dot1q
SW1(config-if)#switchport mode trunk
SW1(config-if)#switchport trunk allowed vlan 10,20
SW2(config)#interface port-channel 12 
SW2(config-if)#switchport trunk encapsulation dot1q 
SW2(config-if)#switchport mode trunk 
SW2(config-if)#switchport trunk allowed vlan 10,20
SW1(config)#interface range ethernet 0/0-1
SW1(config-if-range)#channel-group 12 mode active 
SW1(config-if-range)#no shutdown(这里的端口需要双方接口绑定聚合口后再同时no shutdown)
SW2(config)#interface range ethernet 0/0-1
SW2(config-if-range)#channel-group 12 mode active 
SW2(config-if-range)#no shutdown(这里的端口需要双方接口绑定聚合口后再同时no shutdown)

设置负载均衡模式为源ip到目的ip:

SW1(config)#port-channel load-balance src-dst-ip (设置负载均衡模式为源ip到目的ip)
SW2(config)#port-channel load-balance src-dst-ip 

验证链路聚合和负载均衡:

链路聚合信息

链路聚合信息

这里显示的是链路聚合概要,内容为:组号(Group)为12,端口通道为Po12 SU(S在这里表示二层的意思,U代表正在使用),协议为LACP协商,绑定的链路为以太网0/0-1口。

链路聚合口

箭头所表示为链路聚合后的带宽,为20Mb/s

负载均衡

这里显示的是负载均衡的方式,已经显示为从源ip到目的ip的负载均衡状态。

配置完成后,进行ping测试:

ping测试

ping测试

经过ping测试后,所有的VPC可以跨VALN域进行通信。


文章作者: Naraku
版权声明: 本博客所有文章除特別声明外,均采用 CC BY 4.0 许可协议。转载请注明来源 Naraku !
  目录